1

Closed

Windows Phone Store ® Certification Test Results Fail

description

Hi,

I add slartoolkit.dll for Augmented reality purpose. I working good in my testing mobile(Nokia lumia 510). Then i sent that xap file to Windows app store but they rejected the following reason.

__The application terminates unexpectedly in response to user input.
Steps to Reproduce:__
  1. Launch the application.
  2. Enter valid credentials.
  3. Select "Augmented Reality".
  4. Notice the application unexpectedly terminates.
and they give the following suggestion.

Depending on the underlying cause of the issue encountered, the following resources may provide useful guidance to resolve:
  1. "Product ID": Avoid hard-coded logic based on the original Product ID. If your application design requires using logic based on a Product
    ID, use the Windows Phone Store assigned non-volatile Product ID instead
    (http://msdn.microsoft.com/en-us/library/windowsphone/develop/ff769509(v=vs.105).aspx).
  2. "ScheduledActionService.LaunchForTest Method": This method should only be used during development. You should remove calls to this
    method from your production application
    (http://msdn.microsoft.com/en-us/library/windowsphone/develop/microsoft.phone.scheduler.scheduledactionservice.launchfortest(v=vs.10
    5).aspx).
  3. "Data for Windows Phone | Installation folder": Don’t write to the InstalledLocation folder in your production application release
    submitted for certification (http://msdn.microsoft.com/en-us/library/windowsphone/develop/ff402541(v=vs.105).aspx)
  4. "Capability Detection": Double check that the capabilities required by your application are declared correctly. You can do this by running
    the Windows Phone Capability Detection Tool, as described at How to: Use the Windows Phone Capability Detection Tool
    (http://msdn.microsoft.com/en-us/library/gg180730.aspx).
I don't know what is the problem. and i worked a weeks but till now i have any solution. Please any one give me a suggestion.
Closed Jul 29, 2013 at 1:08 PM by teichgraf
This is not an issue with the library. Please use the discussions forum instead for help requests.
For your case it could by anything. Also make sure to test suspends-resume correctly and see that the camera resource is freed up correctly.
You might want to provide the XAP as well.

comments